Z18 Mobile data not working

Hi, I bought blloc z18.

Unfortunately, I can not make mobile data to work, I’m from Romania and my mobile phone carrier is Vodafone.
Mobile network is set to ‘Vodafone RO’
I need to make some additional configurations ?


Hey @TOvidiu!

Please can you try the following:

Swipe down twice for the Quick Settings, and select Mobile Data. Next at the furthest right of ‘Data usage’ select ’ ⋮ ’ then ‘Mobile networks’

1 - Select network automatically

Go to Network operators > Choose automatically

Go back to the previous screen and check if you are registered on the network

2 - Access Point Names

Select Access Point Names and manually enter your APN. For the correct settings, please confirm with Vodafone RO.

Hope this helps!


I fixed the problem by creating a new APN with the following information:

  • Nume conexiune (connection name): Vodafone Live!
  • APN (access point name): live.vodafone.com
  • Nume utilizator (user name): nu se completeaza (empty)
  • Parola(password): nu se completeaza (empty)
  • Tip APN (apn type): default