Update 3.2.3 not installing

i received the update but after downloading 100% not installing and start downloding again

Can you provide more details?
Have you installed the bllocservices V4 which was pushed along with 3.2.3?

i installed it successfully but the title app is 100 % and repeating the downloading frequently

That percent is for download amount. After that install button will be visible and you need to click that for installing and once installed updates will not appear again

done after trying 3-4 times :+1:t3::+1:t3::+1:t3:

Same here. I tried to install the update more than 20 times.
Nothing happens.

It shows the percentage of the download and after it is complete i click in the bloc service and start the download again.

If I close the blloc services the button indicating the update is still there.

Using a Mi Mix 3 (Android 10)

keep trying several times

  1. Clear data the blloc app
  2. Go to downloads( downloads app of your smartphone), delete all downloaded blloc app
  3. Download update again but do not install in the app
  4. Wait to finish the download. Go to Downloads app again then install blloc files there
1 Like

Tell me if this works

It did not. I tried more that 30 times today.

There is any other way to update?

1 Like

Today I tried this again and it worked.
Thanks!

2 Likes

The same is happening to me. I can’t update…

Hi Warlito,

I’m facing the same issue for 3.2.4 Update.
Which file explorer should I use to view the downloaded file? It cannot be seen by Files app. Kindly let me know.

1 Like

Just find app named “downloads” (in MIUI 11 has an icon as a green square with downsided arrow) - there you should find those files.

1 Like

Hi Stefan,

I can view the file in MIUI downloads but can’t install the file from there. Anyhow it can’t be accessed from other file managers?

Any further insights on it would be helpful.

Thanks,
Rajdeep

Hi there,

As nothing was working I cleared cache and tried but it was of no good either, so I cleared the data but now it asks me to enter a verification code whereas I’m not able to key in my code. What shall I do to access Blloc again?
Kindly let me know.

Thanks,
Rajdeep