Support for Xiomi Redmi Note 5 Pro

Device brand and model:Xiomi Redmi Note 5 Pro

(Include here the name of your device. This must also be the title of the post. E.g. Google Pixel 4)

Ratio version:v3.2.1:22

Problems encountered when using ratio: Colour Feature not Supported & Screen auto rotates even when auto rotation is off

Screenshots:

(Include here the required 6 screenshots of the UI. IMPORTANT: set the display and font size to default)

Screenshot_2020-06-16-14-26-43-240_com.bllocosn|250x500

1 Like

Also Ratio Settings >Tiles > Drawers are buggy

1 Like

U have to install ratio via bllocdesk
Cuz ratio light won’t support grayscale and rotation

@daryankamaran10 I installed ratio from Bllocdesk :sweat_smile:

Really??! Oh, sorry
Then try re installing it

Or restart ratio and chek ur settings if ratio was disabled in accesbility just turn it on

@Chaos how did you install ratio pro on redmi note 5 pro, I tried to install and it said my device was not supported. So I had to stick to ratio lite version. BTW I’m not facing any issues other than auto rotate being a bit slow else all works great for me in the lite version.

I installed Ratio pro version v3.2.1:22 on my Redmi note 5 pro. Works smooth except “Color Feature” not working, getting exactly same message as mentioned by @Chaos.
Tried >>

  1. Reinstalling many times using Bllocdesk
  2. Restart ratio after “enable Grayscale | Color mode” toggle.
  3. Provided accessibility options for “Color Mode” in settings.
    Still not working.

For the “auto rotate” feature, setting auto rotate OFF in device settings will create collision with ratio settings (and please don’t use the “Rotate off” button from notification drawer, keep it disabled ). And we need to:

  1. Keep the “auto rotate screen” feature ON in device settings>>Display
  2. All application will set to “auto” in Ratio by default, if need any change hold and release tile then set rotation.
1 Like

I am also facing the Colour feature problem on my Xiaomi Redmi Y3 but not the rotation problem.

I too am facing the Colour feature issue on my Xiaomi Redmi Y3, and yes I have indeed installed Blloc from BllocDesk.

This is because ratio has not been given permission whole installing. It is for all Xiaomi devices running MIUI.
@HappinessCoder @Chaos

Fix:
While turning on usb debugging, if you look below there’s an option namely “USB Debugging (Security Settings)”. Turn on this option too. Then proceed with the installation using BllocDesk.
This will fix the issue.

2 Likes

Perfect. That worked for me too. Thanks @WIKIJIT.

1 Like

That Worked Thanks !

1 Like

Anyone having this issue :
While using Ratio when i swipe right and go to that left screen where we can get the notes, news and stuff and when i go back to ratio by swiping left, i get that guide ( ratio start guide i.e create a drawer, move app, edit app setting, etc ) popping off every time i get back to home from the left screen.

1 Like

From Ratio settings under the General tab just toggle on the “Disable Onboarding” and your problem should be solved.

Well there’s no option of disable onboarding.

@Chaos I see then this is a bug specific to your device, others the General section should look like this:

I suggest you creating in a new topic under Ratio>Bug reports