[Solved] Error happened premature end of stream, needed one more byte


I’m trying to install on one plus 6t

Make sure you run Blloc desk as admin, have all necessary drivers (I suggest installing fastboot and system vide adb), make sure USB debugging is turned on & USB connection is set to transfer files. If problem persists Reinstall BllocDesk and follow above guidelines

It didnt work.

Here is the logs I got from the Desk app. Might help the developers to debug.

12:08:06.460 › {
  constructor: 'PrematureEOFError',
  name: 'PrematureEOFError',
  message: 'Premature end of stream, needed 1 more bytes',
  missingBytes: 1,
  stack: 'PrematureEOFError: Premature end of stream, needed 1 more bytes\n' +
    '    at Socket.<anonymous> (/Applications/BllocDesk.app/Contents/Resources/app.asar/node_modules/adbkit/lib/adb/parser.js:118:32)\n' +
    '    at Socket.emit (events.js:208:15)\n' +
    '    at endReadableNT (_stream_readable.js:1168:12)\n' +
    '    at processTicksAndRejections (internal/process/task_queues.js:77:11)'
}

This appears on my log everytime device is connected

adb E 44012 17337245 usb_osx.cpp:147] Unable to create an interface plug-in (e00002be)

@olivier we need your attention here.

It happens for me too. But after closed and opened bllocdesk again and phone connects works fine

1 Like

Restart BllocDesk, worked for me.

1 Like

Restarted. Still the same. Are you on Mac or Windows?
I’m on Mac

1 Like

windows here. @jbriones95 and @BobbyV8 please help for MAC issues

Windows here too. Can’t help with MacOS

A clean install and a reboot of the computer did it for many on Windows and Mac. Let us know if that works @vedhavyas

If not, just hold and devs will get to it :slight_smile:

1 Like

Error has nothing to do with Mac in specificity as I believe. Reinstalling Blloc Desk could help, but as I already tagged Olivier, I would wait for his response.

1 Like

I dug around a lil bit. Seems like the APK that was downloaded was corrupted… APK is the issue

Is it working now? Managed to install?

No, I have installed Lite instead of Pro. Waiting for the Devs here to suggest a solution to install PRO

Have you tried reinstalling blloc desk?

I tried again. It worked this time. yay!
thanks!

2 Likes

Nice!.. enjoy ratio… report bugs eh

Good to know it’s solved

It happened to me too, but I just close everything, opened Blloc Desk app again with admin permission, connected my Oneplus 6 and it’s done!