Redmi Y3: Colour shift feature

Device brand and model: Xiaomi Redmi Y3

(Include here the name of your device. This must also be the title of the post. E.g. Google Pixel 4)

Ratio version: 3.2.1:22

Problems encountered when using ratio: Not able to use the Colour shift feature.

Screenshots:


(Include here the required 6 screenshots of the UI. IMPORTANT: set the display and font size to default)

Uhm…I don’t want to sound rude or anything and maybe I’m getting it wrong…but I think you should put your phone brand and model in the title of the post also where currently you are describing the bug. >.<
Might help the devs sorting things out. Maybe “Color Shift Feature on Xiaomi Redmi Y3 not working”

1 Like

This will only work you have installed ratio via bllocdesk. If you have supported devices please uninstall ratio lite and reset code and install pro version with right permissions.

1 Like

Well, he/she could also try to install via Blloc Desk on an unsupported device (like the Redmi Y3 is I think) and see if it works, right?

1 Like

Yes. Possible. But you will get device not supported pop up message anday experience some ui issues

Well, I got that message once on my unsupported phone and haven’t seen it since then so I think it’d be worth a try :slight_smile:

Okie I have mentioned my Device model, but I didn’t get your bug describe part can you please elaborate?

I have installed via Blloc Desk only not via lite.

1 Like

I have installed via Blloc Desk not the lite

Seems like you already changed what I meant though since your title now states your device :slight_smile:

Ok but can you please tell me what permission does Blloc require to enable the colour shift feature?

As far as I know “color mode” in accessibility settings and you gotta turn on “Enable Grayscale” in the general category of ratio settings…hope I’m not missing one but that should be it

2 Likes

I have both the the settings enabled actually but it still doesn’t work :((

1 Like

Hmmm…since it seems like you installed Ratio Pro via Blloc Desk and all required permissions are given…I guess it’s some incompatibility with your device/OS then…

I’m afraid that’s beyond my horizon but maybe there are others in this forum which could help you further…if not, I’m afraid you’ll have to wait and see if the devs are supporting your device one day… :frowning:

1 Like

Ok that’s fine. Thank You very much for the help. Just one more thing can you please mention members of the community specifically whom I should contact regarding this problem for help?

Uhm… I’m kinda new to the forum as well and am not quite aware of the expertise other users might be having.
In the past it proved useful if information about the chipset of the phone and the android version were provided. Maybe you could do that?
Otherwise I’m not quite sure if there is someone we could turn to right now. I’m not sure if the moderators would like to be actively contacted to be honest since your phone isn’t actively supported as of yet and I could understand if they would want to solve issues for unsupported phones at their pacing.

2 Likes

@BobbyV8 came to my mind but like I said…they will probably solve issues like yours at their own pace…

To Bobby: I hope it’s alright I featured you but maybe you could clarify

1 Like

This is because ratio has not been given permission whole installing. It is for all Xiaomi devices running MIUI.
@WIKIJIT @olivier

Fix:
While turning on usb debugging, if you look below there’s an option namely “USB Debugging (Security Settings)”. Turn on this option too. Then proceed with the installation using BllocDesk.
This will fix the issue.

3 Likes

I’m not sure about the part @TheDestroyer said, I need to test it out but I don’t have a Redmi in hand until weekend.

Now to check the permissions…
You need to grant accessibility access to color mode
Usage and notification access to Ratio
If your device lists ratio for draw over other apps… Then that
Allow permissions - restart ratio, reboot device (just to kickstart the whole process)
Turn on greyscale in ratio settings
Turn off color in individual app tile settings

2 Likes

To Be Easy The Solution Is:
Type this in windows terminal “adb shell pm grant com.bllocosn android.permission.WRITE_SECURE_SETTINGS” and click enter.

This Is Not A Bug Or Issue, You’re Missing A Permission That Can Be Granted Via Root Access Or ADB

(Note: USB Debugging In Developer Options Must Be Enabled)

1 Like