Ratio 3.2.8 on Oppo F11 Pro

Can someone enlighten me about this, are this two color mode setting is same? Didnt find any changes about or what was the purpose on this.

Hi,
The setting on Ratio is there to allow for the toggling of greyscale mode on an app by app basis or through the device assistance app (originally Google assistant, but is replaced by Ratio).

Essentially, you can get apps to turn to greyscale by long pressing the app and tapping the color button. Or you can utilise the means to wake Google assistant (which will have been replaced by ratio) to enable or disable monochrome mode.

As to the point of monochrome mode, it is to aid in reducing time spent on an app as monochrome makes things less appealing to people.

Hope this helps out :+1:

Thank you sir for the explanation, it seems that this settings in ratio about greyscale/color mode even it is on and ratio assistance as well, still not working in my device. I cannot even change the color. And what about the color mode in accessibility do i need to turn it on or just leave it off?

1 Like

You don’t have to alter the accessibility settings.

To enable greyscale mode on an app, there are 2 options

  1. Once the app is open, long press the home button. That will shift the app into greyscale. Or if the app is in greyscale, it will shift to color.

  2. In the drawer section, long press an app tile of your choice that you would like in monochrome. For example long press the Gmail app. You will see a dashboard showcasing information about the app with regards to usage At the bottom you will see a row of toggles ie Move, Color, Hide, Lock, Mute and Expand. Tap the color toggle to set the app in greyscale by default. To enable color, long press the home button.

This is what it says when i tap the color

OK, what you need to do is enable the permissions.

  1. Open Ratio settings
  2. Tap the general tab
  3. Scroll down to permissions
  4. Make sure the permissions are granted

Do this then test out if its working :+1:

Oh i see this is what ive missed, cant do it right now anyway dont have a computer/laptop to this

I’ve just gone through my settings abit. Enable the colormode service in accessibility options.
Do that then try again to enable greyscale

Still not work, maybe it well until i grant this two more permission via adb, anyway i got it now sir, ive just downloaded the tools needed right now. Thanks you sir

Welcome,
Kindly inform if it works so that if anyone gets in a similar situation, there is a documented way forward :slightly_smiling_face:.

Yes, i will