Problem with Ratio Play Store licensing

As I quite enjoy Ratio, when the surprising popup about it going paid came up, like a good little boy, I went and bought the lifetime license.

At that time, the license was £39.99, which does sound a lot, but I was okay with it - it is a great launcher after all. The purchase went through on 9th September without a hitch.

Then came a problem with my phone and I needed to do a factory reset. No worries, right? Except… Ratio now can’t restore my previous purchase, AND I’m being offered to buy the lifetime license for £17.99!

I find it infuriating that 1, my license can’t be restored 2, days after I went and bought the early adopter offer, it dropped over 50% in price!

And of course the Play Store offers no recourse/refund either.

What can I do?

2 Likes

Hi sorry for the inconvenience.

I will ask a moderator or admin to escalate this issue you have faced.

Hope it gets addressed.

2 Likes

Turn off Battery optimization,
Enable Auto Launch for the launcher

Restart Ratio Launcher and check

Hey Fonix, this is very odd. I would really like to help you out.
First of all, could you send me a screenshot of the paywall that has the £17.99 price? There is no reason that should be happening for the lifetime option, we definitely don’t have it set lower to what it was before.

Second of all, to restore the purchase, can you make sure of the following:

  • You are logged into the same account on the play store as the one that has the lifetime purchase.
  • You are logged out of other play store accounts.
  • Consider clearing storage/cache on the Play Store, sometimes this will help it re-recognize the purchase.

Another question I have for you, do you have a lot of other subscriptions/purchases on this account?

Best,

Sergey

1 Like

Hi Sergey,

Unfortunately I didn’t take a screenshot of the £17.99 offering, and now it’s back to almost the original price:


I understand that you’re playing around with the Play Store subscription settings, and that it’s causing possible issues (hint: if you’re trialling the subscription side of the Play Store, do that internally first, not on released builds). As a fellow developer, I understand the need to do so for brand new features. However I think it’s incredibly unfair from you to announce the app is going paid, offer a discount for beta testers, then change that offer around on a whim (or an intern’s mistake). As you can see, even in just 5 days, you’ve already changed the pricing around.

To confirm, no, I do not have a lot of subscriptions. Right now I have 6 in total - but that shouldn’t matter since the lifetime option is a buy-it-once IAP, not a subscription.

I’ve tried all the above tricks, in fact I had to reset my phone yesterday (just got that sweet sweet OneUI 4.0 beta and wanted to start with a clean slate). Funny thing - that phone still can’t restore my purchase, AND still buggers me about Ratio going paid tomorrow, but I’ve installed the same version on two other devices I have, and neither have the nag. Nor can they find my license, but I can’t even confirm the pricing without the popup.

I understand your frustration and I apologise for the inconsistencie. Could you confirm the phone model this is happening on? We are looking into the issue at the moment and see an error with restoring purchases happening and want to confirm that the one we are seeing is the one you are having.