OnePlus 7 not supported?

I have a OnePlus 7 (GM1901), BllocDesk says my device is not supported. I thought you advertised OnePlus 7 series in the list of supported devices.

Sorry to hear that but, I own a OnePlus 7 Pro too and didnt have any issues installing Ratio at all. However, this error is pretty common and you can find solutions in this community pages. @jbriones95 where was this posted last?

I don’t have a pro variant. I have a regular OnePlus 7.

Doesnt matter as it starts from OnePlus 7 series. So did you follow the steps mentioned during the installation?

Yes, I turned on USB debugging mode and on step 2 I got a dialogue box telling that my phone is OnePlus 7 and it’s not supported.

Fair enough. I am sure the devs will address it quite well. I aint sure about the solution on my end but my frnds here can help you out. @BobbyV8 @jbriones95

I have an unlocked bootloader I’m not sure if that matters :confused:

1 Like

I dont think that should matter since this is an app (launcher) and not an OS. Your device is definitely supported, check this out https://community.blloc.com/t/ratio-public-roadmap/2680 But there might be some troubleshooting issues. Try to install blloc again and reconnect to see if that works.

1 Like

And may be you’re not the only one. There was a server issue. So id say you give some time and try jt again. https://community.blloc.com/t/error-installing-on-supported-device/2572

Yes, now I’m able to install. Currently it’s on downloading step. I suppose it was a temporary issue. Thanks for your quick response. I really appreciate that.

1 Like

Woow good to know that. And you’re welcome. We are here to help. If you’d also like to share your ideas and interests about ratio or just make like minded friends do join our discord server.

1 Like

I am also not being able to install on OnePlus 7T. It says device not supported, but its clearly in the list of supported devices at https://community.blloc.com/t/ratio-public-roadmap/2680

@BlueSaiyan Please make sure to reboot your computer and try again. Update us here :slight_smile:

@jbriones95 Nope, still getting Unsupported error message.

Please wait for sometime and try again. Also, check if USB debugging is turned on in the settings. In my case I had uninstalled BllocDesk after a few failed attempts then after 30 minutes or so I reinstalled and went through the same procedure and this time when I turned on USB debugging after connecting the USB cable, it worked.

I also downloaded the “Ratio Updates” app given in the email. But there was nothing inside it - “No Updates available”

So, then i downloaded the Ratio application from https://drive.google.com/file/d/1i1xuZNkkxZvb-mpbn1_lvHWtgil9xa86/view - version 3.1.4

Here’s a screenshot


In the lower part of the image, my background image can be seen leaking. Since, it was an older version, i updated the app through “Ratio updates” apk. But I get this message when i enter the licence.

I will probably try the BllocDesk again after a while. :frowning:

@Albatross
Yes, USB debugging is on. I have also tried uninstalling and installing it again, but getting the same device not supported message.

Okay I will try again after sometime, Lets see.

7T-Pro here, also not supported

@deerhall It seems you have to wait for the survey email. After that everything works (I hope so :crossed_fingers:)

I recieved my invite 5 hours ago, how long should we wait for survey?