Huawei Rio-100(g7)

I use Huawei Rio-100 emui4.0.2 android version 8.1 , I got invites for the blloc community as well as download link but after downloading I get d error message that says I use a device version lower than 8.1, kindly assist me here, anyone pls

1 Like