Guide : Enable the System-wide Permissions For Ratio Using Ratio Tool in Oppo / Realme devices

Hey Ratio fans,

Hope you all are doing well!
You all have heard about the Ratio 4 release and its Available in Play Store for everyone…

I knew some of you guys really liked the new Minimalistic design and Translucent theme…
Hope you enjoying it.

Some might Likes the Grayscale overlay in Entire OS and there are few Users complaining about the enabling the permission Issues on Color OS / Realme UI devices (Oppo / Realme)

For that here’s the solution :

  1. Open the settings => About Phone =>

  1. Tap “Baseband & Kernel”

  1. Then tap the Build number to Enable the Developer Options.

  1. Back to the settings Page => Open Additional Settings => Developer Options

  1. Click “Enable USB Debugging”

  2. Here’s the catch from Color OS… You have to enable the iption called “Disable Permission Monitoring” so that you can enable the system wide permissions for Ratio

After that Download the Ratio Tool for Windows or Ratio Tool for Mac
To enable Permission (This Tool will Do all the Permission Job For you Within a Second…

Thanks :smiling_face_with_three_hearts: to the Developers for the Amazing :fire: work.

Thanks :slightly_smiling_face:,
Hudson Hitman J.

9 Likes

Ah, so is that what was preventing my Samsung Galaxy from being recognised by the Desktop tool.
I resorted to adb which on Windows 10 wasn’t actually that difficult with the help of the XDA Developers article and tool download.

Hope this link will help those still struggling with the Desktop tool, really it looks scary but it’s actually very straight forward just follow the instructions and input the adb code quoted on your device or ask for it in the forum.
The only thing I would add is that on Windows 10 the adb command has changed so instead of adb at the start you now have to enter ./adb I think it’s a forward slash if that doesn’t work use a back slash but Windows will tell you if there’s an input error so just keep trying, there’s also no confirmation you’ve succeeded it just opens a new prompt so just come out of all your screens on your device then go back into Ratios Settings / Permissions and see if you can grant the missing permissions.

2 Likes

Yea there’s a adb command for enable the permission manually but not every user’s are familiar with adb things so I ignored that Intentionally…

If users want the Manual Command I’ll provide here. :wink:

1 Like

Thanks bro ,it worked for my realme narzo 20 pro running on realme ui 1.0, while some error message has come ,i have just ignored and closed that pop up window,and then its done,color mode activated.

1 Like

You’re welcome :wink:

Hello, I am using Ration for more than a year, earlier on Nokia and now on Realme. but the Greyscale overlay never. worked for me. I tried using the method mentioned above but it didn’t work. even though the Ratio tool says I can now use colour more and lock on my apps. my phone is running on Android 11 and Realme UI2.0 can anyone please help ? Thanks

You have to go to the settings and enable something along the lines of “Use greyscale for apps”.

Stuck at the usb debugging thing…

Have you tried Restarting PC (or) Mobile device… Because sometimes for the first time it’ll happen like this… Restarting will fix this.

1 Like