Blloc desk phone detection problem

Hey there, recently I downloaded Ratio on my realme 6 pro, and I found it awesome, but to activate colour mode I wanted to use blloc desk, unfortunately, Blloc desk was not able to detect my device even after I turned on USB debugging, can anyone help me out with this problem,

2 Likes

Hi Tarang,
I had the same issue, if you have access to a Windows PC check out this article from XDA Developers on adb, hope it helps.

hey, thank you, i tried typing adb command which is mentioned in permissions menu, and the execution was

what to do next idk!

Hi Tarang,
If you have followed the XDA walkthrough and it looks to me like you have there is an error in their advise.
Unpacking and running the adb tool from C:\ as stated results in the error message your seeing because of permission issues in that directory.
Unpack the adb zip in " Downloads " and run from there and you should have no problems.
Let me know how you get on.

But my question is what to do after the ADB process, how can I grant permission on my phone. You can guide me directly using snapchat, @tiku0143 if you don’t mind

Sadly I don’t use Snapchat.
Have you successfully run the adb tool now ?
if not what adb command are you useing ?
You will know if the process completed because Windows will simply return to a new command prompt in the shell, then if you open Ratio Settings / General / Permission Manager you will now be able to grant the missing permissions.
I am sure you are very close to cracking this so I will assist you until a successfull conclusion.

Brother, i really appreciate your patience. I used the adb command which is provided in permissions menu(see the image below). What things to do in Pc, can you say it off in detail from beginning
Screenshot_2021-01-04-23-41-18-03_4c7f77359c71f846ef6dbee846ef57e7|225x500 it would be easier if we talk on any social media. Which social app you use?

Have you tried using ratio tool?

1 Like

Ratio tool is not able to detect my phone

This issue was resolved off forum at the request of the postie so I have posted the outcome here for the benefit of all those following this thread.
After a very in depth conversation between Tarang and myself acompanied by many screenshots we exhausted all possible courses of action until a solution was found, I am pleased to confirm the user has successfully granted all the missing permissions.

SOLUTION: After successfully running the Ratio Desktop Tool a reboot of the device was required to finalise the settings.

Hope this information will prove useful to others.

Yeah you made that possible :grin::facepunch:

But what to do when phone is not detected?

Try this method.

Looks like your trying to run the adb tool from C:\

Unpack and run the adb tool from your " Downloads Folder " instead to avoid the permissions issue.

The process is as follows :

Open a command shell from within the unpacked adb tool then Run the following commands in order.

  1. .\adb devices

  2. .\adb shell pm grant com.bllocosn android.permission.WRITE_SECURE_SET TINGS

Reboot Device to complete the process.

Once rebooted go into Ratio / General Settings / Permissions and grant the missing permissions.

Ok… Will try with above steps… Infect i tried in after extract adb in C drive only.

Hi Cbpandya,
Just wondering how you got on, did you succeed with the adb method ?

No… I tried as you suggested but didn’t worked…

Bro i don’t even know i got succeed, but there no big use of that

Ok bro…but no big use of what… Permissions?